Skip to main content
CVE-2026-27172VulnerabilityPublished Updated

Org.apache.camel:camel consul: Apache Camel-Consul component vulnerable to Deserialization of Untrusted Data

Affects org.apache.camel:camel-consulSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-27172· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade to 4.14.6 soon.

Data as of 27 Oct 2026, 00:07 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.14.6, 4.18.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.apache.camel:camel-consul to 4.14.6; org.apache.camel:camel-consul to 4.18.1.

Affected software

ProductAffectedFixed in
Mavenorg.apache.camel:camel-consulAffected
  • >=3.0.0 <4.14.6
Fixed in
  • 4.14.6
Mavenorg.apache.camel:camel-consulAffected
  • >=4.15.0 <4.18.1
Fixed in
  • 4.18.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

The ConsulRegistry in the camel-consul component (class org.apache.camel.component.consul.ConsulRegistry and its inner ConsulRegistryUtils.deserialize method) read Java-serialized values from the Consul KV store and passed them to ObjectInputStream.readObject() without configuring an ObjectInputFilter. An attacker who can write to the Consul KV store backing a Camel ConsulRegistry instance could inject a malicious serialized Java object that is deserialized the next time Camel performs a lookup against that registry, leading to arbitrary code execution in the Camel process. The issue mirrors the class of vulnerability already addressed for other Camel components in CVE-2024-22369, CVE-2024-23114 and CVE-2026-25747, and was overlooked during the original remediation of those CVEs. This issue affects Apache Camel: from 3.0.0 before 4.14.6, from 4.15.0 before 4.18.1. Users are recommended to upgrade to version 4.19.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.6. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.1.

References

Community reviews

Loading reviews…