Skip to main content
VulnerabilityPublished Updated

CVE-2026-25747: Apache Camel LevelDB · Deserialization of Untrusted Data

Affects Apache Camel LevelDBSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High · fixed in 4.18.0 : patch Apache Camel LevelDB soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.2% chance of exploitation in 30 days – higher than 69% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.18.0, 4.14.5, 4.10.9 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache Camel LevelDB and Apache Software Foundation/org.apache.camel:camel-leveldb to 4.18.0, 4.14.5 or 4.10.9; org.apache.camel/camel-leveldb to 4.18.0, 4.14.5 or 4.10.8.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Camel LevelDBAffected
  • >=4.15.0 <4.18.0
Fixed in
  • 4.18.0
Apache Software FoundationApache Camel LevelDBAffected
  • >=4.14.0 <4.14.5
Fixed in
  • 4.14.5
Apache Software FoundationApache Camel LevelDBAffected
  • >=3.0.0 <4.10.9
Fixed in
  • 4.10.9
Mavenorg.apache.camel/camel-leveldbpkg:maven/org.apache.camel/camel-leveldbOther threatsAffected
  • <4.10.8
  • >=4.10.0
  • <4.14.5
  • >=4.14.0
  • <4.18.0
  • >=4.15.0
Fixed in
  • 4.10.8
  • 4.14.5
  • 4.18.0
MavenApache Software Foundation/org.apache.camel:camel-leveldbpkg:maven/Apache Software Foundation/org.apache.camel:camel-leveldbOther threatsAffected
  • >=3.0.0 <4.10.9
  • >=4.14.0 <4.14.5
  • >=4.15.0 <4.18.0
Fixed in
  • 4.10.9
  • 4.14.5
  • 4.18.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade affected Apache Camel LevelDB component versions to 4.10.9, 4.14.5, or 4.18.0 as appropriate. Red Hat's advisory states that no other mitigations currently meet their criteria for ease of use, applicability, or stability. Users should ensure that only trusted entities have write access to LevelDB database files as a general security measure. Patch status is confirmed: fixed versions are available.

Description

Deserialization of Untrusted Data vulnerability in Apache Camel LevelDB component. The Camel-LevelDB DefaultLevelDBSerializer class deserializes data read from the LevelDB aggregation repository using java.io.ObjectInputStream without applying any ObjectInputFilter or class-loading restrictions. An attacker who can write to the LevelDB database files used by a Camel application can inject a crafted serialized Java object that, when deserialized during normal aggregation repository operations, results in arbitrary code execution in the context of the application. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.5, from 4.15.0 before 4.18.0. Users are recommended to upgrade to version 4.18.0, which fixes the issue. For the 4.10.x LTS releases, users are recommended to upgrade to 4.10.9, while for 4.14.x LTS releases, users are recommended to upgrade to 4.14.5

References

Community reviews

Loading reviews…