CVE-2024-44088: Org.apache.geode:geode web api: Apache Geode web-api is vulnerable to Cross-site Scripting
Affects org.apache.geode:geode-web-apiSource GCVE Database
Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.15.2 when convenient.
Data as of 4 Nov 2026, 17:16 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 6.1 |
|---|
- Patch
- Available – fixed in 1.15.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade org.apache.geode:geode-web-api to 1.15.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.apache.geode:geode-web-api | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user's session information and even account takeover. This issue affects Apache Geode: all versions prior to 1.15.2. Users are recommended to upgrade to version 1.15.2, which fixes the issue.