CVE-2024-44088: Apache Geode · Cross-site Scripting
Affects Apache GeodeSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium · fixed in 1.15.2 : update Apache Geode when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.15.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software Foundation Apache Geode | Affected
| Fixed in– |
AI-suggested
- Immediate upgrade to Apache Geode version 1.15.2 or later, which contains the patch for this XSS vulnerability.
- Implement strict input validation and output encoding on all user-supplied data in web applications interfacing with Apache Geode to reduce risk of injection attacks.
- Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers.
- Educate users and staff about phishing risks and the dangers of clicking suspicious links, as user interaction is required for exploitation.
- Monitor web application logs and network traffic for unusual requests or patterns indicative of attempted XSS attacks.
- Use web application firewalls (WAFs) with rules designed to detect and block XSS payloads targeting Apache Geode endpoints.
- Conduct regular security assessments and penetration testing focusing on web API endpoints to identify and remediate injection flaws proactively.
Description
Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user's session information and even account takeover. This issue affects Apache Geode: all versions prior to 1.15.2 Users are recommended to upgrade to version 1.15.2, which fixes the issue.