Skip to main content
VulnerabilityPublished

CVE-2025-66200: Apache HTTP Server · mod_userdir+suexec bypass via AllowOverride FileInfo

Affects Apache HTTP ServerSource CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium · fixed in 2.4.66 : update Apache HTTP Server when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.66
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • =2.4.7
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade Apache HTTP Server to version 2.4.66 or later immediately to apply the official patch addressing this vulnerability.
  2. Review and restrict the use of AllowOverride directives, particularly limiting or disabling FileInfo overrides in .htaccess files unless absolutely necessary.
  3. Audit all .htaccess files for the use of the RequestHeader directive and remove or restrict permissions for untrusted users to modify these files.
  4. Harden suexec configurations by ensuring that only trusted users can deploy CGI scripts and that suexec wrappers are properly configured to enforce user boundaries.
  5. Implement strict access controls on web server directories to prevent unauthorized modifications to .htaccess files.
  6. Monitor web server logs for unusual CGI script executions or unexpected user IDs running scripts, which may indicate exploitation attempts.
  7. Employ web application firewalls (WAFs) to detect and block suspicious HTTP header manipulations related to RequestHeader usage.
  8. Conduct regular security assessments and penetration testing focusing on web server configurations and privilege boundaries to detect similar misconfigurations.

Description

mod_userdir+suexec bypass via AllowOverride FileInfo vulnerability in Apache HTTP Server. Users with access to use the RequestHeader directive in htaccess can cause some CGI scripts to run under an unexpected userid. This issue affects Apache HTTP Server: from 2.4.7 through 2.4.65. Users are recommended to upgrade to version 2.4.66, which fixes the issue.

References

Community reviews

Loading reviews…