Skip to main content
CVE-2025-49656VulnerabilityPublished Updated

Org.apache.jena:jena fuseki: Apache Jena allows users with administrator access to create databases files outside the

Affects org.apache.jena:jena-fusekiSource GCVE Database

0
Compare
Authoritative record:CVE-2025-49656· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 5.5.0 soon.

Data as of 4 Nov 2026, 18:15 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
Patch
Available – fixed in 5.5.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.jena:jena-fuseki to 5.5.0.

Affected software

ProductAffectedFixed in
Mavenorg.apache.jena:jena-fusekiAffected
  • <5.5.0
Fixed in
  • 5.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Jena Fuseki to version 5.5.0 or later, where this vulnerability is fixed. Since a patch is available, applying this official fix is the recommended remediation.

Description

Apache Jena Fuseki versions prior to 5.5.0 contain a vulnerability that allows users with administrator privileges to create database files outside the designated files area of the Fuseki server. This directory traversal issue could lead to unauthorized file creation in unintended locations. The vulnerability has a CVSS score of 4.9, indicating medium severity. The issue is fixed in version 5.5.0.

References

Community reviews

Loading reviews…