Skip to main content
CVE-2025-24853VulnerabilityPublished Updated

Org.apache.jspwiki:jspwiki main: Apache JSPWiki Cross-Site Scripting (XSS) Vulnerability via Header Link Rendering

Affects org.apache.jspwiki:jspwiki-mainSource GCVE Database

0
Compare
Authoritative record:CVE-2025-24853· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 2.12.3 soon.

Data as of 4 Nov 2026, 17:16 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
Patch
Available – fixed in 2.12.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.jspwiki:jspwiki-main and org.apache.jspwiki:jspwiki-markdown to 2.12.3.

Affected software

ProductAffectedFixed in
Mavenorg.apache.jspwiki:jspwiki-mainAffected
  • <2.12.3
Fixed in
  • 2.12.3
Mavenorg.apache.jspwiki:jspwiki-markdownAffected
  • <2.12.3
Fixed in
  • 2.12.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A carefully crafted request when creating a header link using the wiki markup syntax, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Further research by the JSPWiki team showed that the markdown parser allowed this kind of attack too. Apache JSPWiki users should upgrade to 2.12.3 or later.

References

Community reviews

Loading reviews…