Org.apache.jspwiki:jspwiki main: Apache JSPWiki Cross-Site Scripting (XSS) Vulnerability in the Image Plugin
Affects org.apache.jspwiki:jspwiki-mainSource GCVE Database
Not known to be exploited · CVSS 6.1 Medium : upgrade to 2.12.3 when convenient.
Data as of 4 Nov 2026, 18:16 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 6.1 |
|---|
- Patch
- Available – fixed in 2.12.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade org.apache.jspwiki:jspwiki-main to 2.12.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.apache.jspwiki:jspwiki-main | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache JSPWiki to version 2.12.3 or later, where this vulnerability is fixed. Since a patch is available and the fixed version is explicitly stated, applying this update fully mitigates the risk. No additional mitigation steps are indicated by the vendor.
Description
Apache JSPWiki versions prior to 2.12.3 contain a cross-site scripting (XSS) vulnerability in the Image plugin. This flaw allows an attacker to execute arbitrary JavaScript in the context of a victim's browser, potentially exposing sensitive information. Users are advised to upgrade to version 2.12.3 or later to remediate this issue.