CVE-2025-24854: Apache JSPWiki · Cross-site Scripting
Affects Apache JSPWikiSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium · fixed in 2.12.3 : update Apache JSPWiki when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.12.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software Foundation Apache JSPWiki | Affected
| Fixed in– |
AI-suggested
European organizations should immediately upgrade Apache JSPWiki installations to version 2.12.3 or later, where the vulnerability is patched. Beyond patching, administrators should audit and restrict the use of the Image plugin or any other plugins that process user input, ensuring they are configured securely or disabled if unnecessary. Implement Content Security Policy (CSP) headers to restrict the execution of untrusted scripts in browsers accessing JSPWiki instances. Conduct regular security training to raise user awareness about the risks of interacting with suspicious links or content. Employ web application firewalls (WAFs) with rules tailored to detect and block XSS payloads targeting JSPWiki. Additionally, review and sanitize all user-generated content inputs at the application level to prevent injection of malicious scripts. Monitoring logs for unusual activity related to JSPWiki can help detect attempted exploitation. Finally, maintain an up-to-date inventory of all open-source components in use to ensure timely application of security updates.
Description
A carefully crafted request using the Image plugin could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.3 or later.