DataGerry before 3.3.0 contains a server-side template injection vulnerability that allows authenticated attackers
Affects DataGerrySource GCVE Database
Not known to be exploited · CVSS 8.7 High : upgrade to 3.3.0 soon.
Data as of 4 Nov 2026, 19:44 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.7 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 8.8 |
- Affects
- Docker deployments. DataGerry before 3.3.0
- Patch
- Available – fixed in 3.3.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade datagerry/DataGerry to 3.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubdatagerry/DataGerrypkg:github/datagerry/DataGerryOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict access to users with the base.docapi.template.add permission and consider isolating or limiting the privileges of the DataGerry web process user to reduce impact.
Description
DataGerry versions prior to 3.3.0 have a server-side template injection vulnerability that allows authenticated users with specific permissions to inject and execute arbitrary Jinja2 payloads. This vulnerability enables remote code execution as the web process user, which is root by default in Docker deployments.