Skip to main content
VulnerabilityPublished

Org.opensearch.plugin:opensearch security: OpenSearch has a bypass of REST Layer Authorization Using Malformed Paths

Affects org.opensearch.plugin:opensearch-securitySource GCVE Database

0

CVSS 3.7 Low : upgrade to 2.19.0.0 when convenient.

Data as of 27 Oct 2026, 02:27 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.19.0.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

What to do

Upgrade org.opensearch.plugin:opensearch-security to 2.19.0.0.

Affected software

ProductAffectedFixed in
Mavenorg.opensearch.plugin:opensearch-securityAffected
  • >=2.11.0.0 <2.19.0.0
Fixed in
  • 2.19.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected OpenSearch instances to version 2.19.0 or later, where this vulnerability is fixed. No additional mitigation is required for default OpenSearch distributions. Users employing custom plugins should ensure they upgrade promptly to prevent unauthorized access.

Description

A vulnerability in the OpenSearch REST layer allows bypassing authorization checks via malformed HTTP requests, potentially granting unauthorized read access to certain API endpoints. The default OpenSearch distribution is not affected due to transport-level authorization enforcement. Custom plugins that register REST actions without corresponding transport actions may be vulnerable. The issue is fixed in OpenSearch version 2.19.0.

References

Community reviews

Loading reviews…