Skip to main content
VulnerabilityPublished

Org.opensearch.plugin:opensearch security: OpenSearch vulnerable to improper authorization for Rollover Requests

Affects org.opensearch.plugin:opensearch-securitySource GCVE Database

0

CVSS 2.2 Low : upgrade to 2.19.4.0 when convenient.

Data as of 27 Oct 2026, 02:27 UTC

CVSS 3.1 base score
2.2Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.19.4.0, 3.2.0.0
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:N

What to do

Upgrade org.opensearch.plugin:opensearch-security to 2.19.4.0; org.opensearch.plugin:opensearch-security to 3.2.0.0.

Affected software

ProductAffectedFixed in
Mavenorg.opensearch.plugin:opensearch-securityAffected
  • >=1.0.0 <2.19.4.0
Fixed in
  • 2.19.4.0
Mavenorg.opensearch.plugin:opensearch-securityAffected
  • >=3.0.0 <3.2.0.0
Fixed in
  • 3.2.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading to OpenSearch versions 2.19.4.0 or 3.2.0.0 where this issue is fixed. Until patched, restrict the 'indices:admin/rollover' permission to fully trusted users only to prevent exploitation.

Description

A vulnerability in the OpenSearch Security plugin allows improper authorization checks during index rollover requests. Specifically, when a rollover request specifies an explicit target index name, the plugin fails to properly verify access permissions for the target index. This flaw enables users with rollover permissions on a source index to create new indices with unauthorized names. The issue affects OpenSearch versions prior to 2.19.4.0 and 3.2.0.0 and has a low severity rating. Fixed versions are available.

References

Community reviews

Loading reviews…