Skip to main content
CVE-2025-48866VulnerabilityPublished Updated

Bundesamt für Sicherheit in der Informationstechnik Amazon · OWASP ModSecurity: Schwachstelle ermöglicht Denial of Service

Affects Bundesamt für Sicherheit in der Informationstechnik AmazonSource GCVE Database

0
Compare
Authoritative record:CVE-2025-48866· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 2.9.10 soon.

Data as of 4 Nov 2026, 17:49 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.9.10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade owasp-modsecurity/ModSecurity to 2.9.10.

Affected software

ProductAffectedFixed in
GitHubowasp-modsecurity/ModSecuritypkg:github/owasp-modsecurity/ModSecurityOther threatsAffected
  • <2.9.10
Fixed in
  • 2.9.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixes for this vulnerability have been released by vendors. Users should apply the available updates to ModSecurity packages provided by their Linux distribution vendors. For Ubuntu, standard system updates or Ubuntu Pro Extended Security Maintenance (ESM) provide the fixes. For Red Hat Enterprise Linux 9, updated mod_security packages are available and should be installed promptly. No additional mitigation steps are required beyond applying these official patches.

Description

ModSecurity, an open source web application firewall, contains a vulnerability (CVE-2025-48866) related to improper handling of certain form data. This flaw can be exploited by an attacker to cause a denial of service (DoS) condition. The issue affects multiple Linux distributions including Ubuntu and Red Hat Enterprise Linux. Fixes have been released by vendors and are available through standard system updates or extended support services.

References

Community reviews

Loading reviews…