Skip to main content
CVE-2026-119569VulnerabilityPublished

Parse Server before 8.6.108 and 9.0.0 before 9.10.5-alpha.9 contains a prototype pollution vulnerability because

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-119569· Medium 6.0

Not known to be exploited · CVSS 6.0 Medium : upgrade to 9.10.5-alpha.9 when convenient.

Data as of 30 Oct 2026, 16:51 UTC

CVSS 4.0 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.0
CNA (VulnCheck)CVSS 3.15.3
Patch
Available – fixed in 9.10.5-alpha.9, 8.6.108
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.10.5-alpha.9; parse-server to 8.6.108; parse-server to 9.10.5-alpha.9 or 8.6.108.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.10.5-alpha.9
Fixed in
  • 9.10.5-alpha.9
parse-communityparse-serverAffected
  • <8.6.108
Fixed in
  • 8.6.108
npmparse-serverpkg:npm/parse-serverOther threatsAffected
  • >=9.0.0 <9.10.5-alpha.9
  • <8.6.108
Fixed in
  • 9.10.5-alpha.9
  • 8.6.108

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Parse Server versions 8.6.108 and 9.10.5-alpha.9 and later. Users should upgrade to these versions or later to remediate the vulnerability. No other mitigation or temporary workaround is indicated. Since this is not a cloud service, patching the server software is required.

Description

Parse Server versions before 8.6.108 and 9.0.0 before 9.10.5-alpha.9 are affected by a prototype pollution vulnerability. This occurs because user-controlled keys are expanded into objects without checking for own properties. Attackers with class write access can send specially crafted keys using dot notation or ACL entry names that match built-in object members. This can corrupt built-in functions, causing all requests to the server to fail until it is restarted.

References

Community reviews

Loading reviews…