Parse Server before 8.6.110 and 9.0.0 before 9.10.6-alpha.2 fails to contain a serialization error when an object
Source GCVE Database
Not known to be exploited · CVSS 8.2 High : upgrade to 9.10.6-alpha.2 soon.
Data as of 3 Nov 2026, 16:30 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.2 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.9 |
- Patch
- Available – fixed in 9.10.6-alpha.2, 8.6.110
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade parse-server to 9.10.6-alpha.2; parse-server to 8.6.110; parse-server to 9.10.6-alpha.2 or 8.6.110.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-serverpkg:npm/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Parse Server versions 8.6.110 and 9.10.6-alpha.2 and later. Users should upgrade to these or newer versions to remediate the vulnerability. No vendor advisory or patch links were provided, so confirm patch availability from official Parse Server sources before upgrading. If upgrading is not immediately possible, restrict object write permissions to authenticated sessions to reduce exposure.
Description
Parse Server versions before 8.6.110 and 9.0.0 before 9.10.6-alpha.2 contain a vulnerability where a serialization error is not properly handled during an object update using a dot notation key targeting a pointer field's object identifier on a class with an afterSave trigger. This flaw allows attackers, including unauthenticated clients if objects are writable without a session, to send such updates and cause the Node.js process to crash, resulting in a denial of service.
References
- github.com/parse-community/parse-server/security/advisories/GHSA-wc3c-6843-q7mv (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-121414 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10802 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10803 (opens in a new tab)
- vulncheck.com/advisories/parse-server-before-8.6.110-and-9.0.0-before-9.10.6-alpha.2-denial-of-service-via-aftersave-pointer-update (opens in a new tab)