svg-sanitizer from 1.1.0 before 1.1.1 contains a denial of service vulnerability that allows remote attackers to crash
Affects svg-sanitizerSource GCVE Database
Not known to be exploited · CVSS 6.9 Medium : upgrade to 1.1.1 when convenient.
Data as of 3 Nov 2026, 16:15 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.9 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.3 |
- Patch
- Available – fixed in 1.1.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade darylldoyle/svg-sanitizer to 1.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Packagistdarylldoyle/svg-sanitizerpkg:composer/darylldoyle/svg-sanitizerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version 1.1.1 or later should be used to remediate this issue. Until patched, avoid processing untrusted SVG inputs or implement input validation to reject truncated or malformed SVG content.
Description
A denial of service vulnerability exists in svg-sanitizer versions from 1.1.0 before 1.1.1. Remote attackers can cause a crash by submitting SVG input that ends inside an unclosed tag, such as a truncated input with a single '<'. This triggers an uncaught ValueError in PHP 8 functions, causing the request to fail.