Skip to main content
CVE-2026-121965VulnerabilityPublished

Parse Server before 8.6.113 and 9.0.0 before 9.10.6-alpha.5 contains a prototype pollution vulnerability when building

Affects parse-serverSource GCVE Database

0
Compare
Authoritative record:CVE-2026-121965· Medium 6.0

Not known to be exploited · CVSS 6.0 Medium : upgrade to 9.10.6-alpha.5 or 8.6.113 when convenient.

Data as of 4 Nov 2026, 19:45 UTC

CVSS 4.0 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.0
CNA (VulnCheck)CVSS 3.15.3
Patch
Available – fixed in 9.10.6-alpha.5, 8.6.113
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade parse-community/parse-server to 9.10.6-alpha.5 or 8.6.113.

Affected software

ProductAffectedFixed in
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threatsAffected
  • <8.6.113
  • >=9.0.0 <9.10.6-alpha.5
Fixed in
  • 8.6.113
  • 9.10.6-alpha.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Parse Server versions 8.6.113 and 9.10.6-alpha.5 and later. Users should upgrade to these or newer versions to remediate the vulnerability. No other mitigation or temporary workaround is indicated.

Description

Parse Server versions before 8.6.113 and 9.0.0 before 9.10.6-alpha.5 contain a prototype pollution vulnerability affecting Cloud Code triggers and LiveQuery. This flaw allows clients with write access to corrupt built-in functions by exploiting dot notation keys that traverse inherited members, causing denial of service until the server is restarted.

References

Community reviews

Loading reviews…