Skip to main content
VulnerabilityPublished

CVE-2026-110672: perl-Cpanel-JSON-XS security update

Affects perl-Cpanel-JSON-XSSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-110672· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 4.80-1.oe2403sp1 soon.

Data as of 4 Nov 2026, 16:58 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
Patch
Available – fixed in 4.80-1.oe2403sp1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade perl-Cpanel-JSON-XS to 4.80-1.oe2403sp1.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP1perl-Cpanel-JSON-XSpkg:rpm/openEuler/perl-Cpanel-JSON-XS&distro=openEuler-24.03-LTS-SP1Other threatsAffected
  • <4.80-1.oe2403sp1
Fixed in
  • 4.80-1.oe2403sp1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version 4.80-1.oe2403sp1 of perl-Cpanel-JSON-XS is available and should be applied to remediate these vulnerabilities. Users should upgrade to this version to prevent memory leaks, crashes, and memory exhaustion caused by malformed or malicious JSON input. No other mitigations are specified or required.

Description

perl-Cpanel-JSON-XS versions before 4.80-1.oe2403sp1 contain multiple security vulnerabilities including memory leaks, type confusion, memory exhaustion, and out-of-bounds writes. These issues arise from improper handling of duplicate keys, malformed UTF-8 in keys, large numeric exponents, incremental parsing buffers, and canonical encoding of tied or shared hashes. The vulnerabilities can lead to process crashes, memory exhaustion, and potential denial of service. A fixed version 4.80-1.oe2403sp1 is available addressing these issues.

References

Community reviews

Loading reviews…