Skip to main content
CVE-2026-116241VulnerabilityPublished

pgAdmin 4's Import/Export Data tool wraps a user's query export in a psql \copy (...) TO command and checks that the

Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-116241· Critical 9.9

Not known to be exploited · CVSS 9.9 Critical : upgrade to 9.19 as a priority.

Data as of 30 Oct 2026, 23:35 UTC

CVSS 3.1 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (PostgreSQL)CVSS 3.19.9
CNA (PostgreSQL)CVSS 4.09.4
Patch
Available – fixed in 9.19
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade pgAdmin 4 to 9.19.

Affected software

ProductAffectedFixed in
pgadmin.orgpgAdmin 4Affected
  • <9.19
Fixed in
  • 9.19
GitHubpgAdmin 4pkg:github/pgAdmin 4Other threatsAffected
  • <9.19
Fixed in
  • 9.19

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade pgAdmin 4 to version 9.19 or later, where this vulnerability is fixed by rejecting any backslash inside double-quoted identifiers during query validation. Until upgrading, restrict Import/Export Data permissions to trusted users only and ensure that database roles do not disable standard_conforming_strings. Monitor vendor advisories for additional guidance. Patch status is confirmed fixed in pgAdmin 4 version 9.19.

Description

pgAdmin 4 versions before 9.19 contain a critical vulnerability in the Import/Export Data tool. The tool wraps user queries in a psql \copy (...) TO command and attempts to validate balanced parentheses to prevent command injection. However, it incorrectly handles backslashes inside double-quoted identifiers, allowing an attacker to bypass this check and inject a TO PROGRAM clause. This clause executes arbitrary commands on the pgAdmin host with the operating system privileges of the pgAdmin process. The vulnerability arises because the server setting standard_conforming_strings can be turned off by ordinary database roles, affecting how backslashes are interpreted, which pgAdmin does not reliably account for. This issue is a bypass of the previous fix for CVE-2026-17566.

References

Community reviews

Loading reviews…