Skip to main content
VulnerabilityPublished

CVE-2026-116241: pgAdmin 4 · OS Command Injection

Affects pgAdmin 4Source CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 9.9 Critical : upgrade to 9.19 as a priority.

Data as of 30 Oct 2026, 20:18 UTC

CVSS 3.1 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (PostgreSQL)CVSS 3.19.9
CNA (PostgreSQL)CVSS 4.09.4
Patch
Available – fixed in 9.19
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade pgAdmin 4 to 9.19.

Affected software

ProductAffectedFixed in
pgadmin.orgpgAdmin 4Affected
  • <9.19
Fixed in
  • 9.19
GitHubpgAdmin 4pkg:github/pgAdmin 4Other threatsAffected
  • <9.19
Fixed in
  • 9.19

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade pgAdmin 4 to version 9.19 or later, where this vulnerability is fixed by rejecting backslashes inside double-quoted identifiers during query validation. No other mitigations are indicated by the vendor advisory.

Description

CVE-2026-116241 is a critical OS command injection vulnerability in pgAdmin 4 versions before 9.19. It arises from improper handling of backslashes inside double-quoted identifiers in the Import/Export Data tool's query export feature. This flaw allows an attacker with non-administrative database role permissions to execute arbitrary OS commands on the host running pgAdmin by exploiting a discrepancy in how pgAdmin and psql parse quoted strings when standard_conforming_strings is turned off. The issue bypasses a previous fix and is resolved in pgAdmin 4 version 9.19.

References

Community reviews

Loading reviews…