Skip to main content
VulnerabilityPublished

CVE-2026-46629: Php twig · Twig is a template language for PHP

Affects php-twigSource GCVE Database

0
Authoritative record:CVE-2026-46629· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium · fixed in 3.26.0 : update php-twig when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.26.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10php-twigpkg:deb/ubuntu/php-twig?arch=source&distro=stonkingOther threatsAffected
  • =3.23.0-2build7
  • =3.27.1-1
  • =3.28.0-1
Fixed in–
Ubuntu Pro 26.04 LTSphp-twigpkg:deb/ubuntu/php-twig?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • 3.20.0-2ubuntu1 – 3.23.0-2ubuntu0.1~esm1
4 affected builds
Fixed in–
Ubuntu 25.10php-twigpkg:deb/ubuntu/php-twig?arch=source&distro=questingOther threatsAffected
  • =3.20.0-2ubuntu1
Fixed in–
Ubuntu Pro 24.04 LTSphp-twigpkg:deb/ubuntu/php-twig?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 3.7.0-1 – 3.8.0-2ubuntu1+esm1
6 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSphp-twigpkg:deb/ubuntu/php-twig?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 3.3.2-1ubuntu3 – 3.3.8-2ubuntu4+esm2
7 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSphp-twigpkg:deb/ubuntu/php-twig?arch=source&distro=esm-apps/focalOther threatsAffected
  • 2.11.3-2 – 2.12.5-1ubuntu0.1~esm2
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Twig to version 3.26.0 or later, where this issue is fixed. No other mitigation or temporary workaround is indicated in the available data.

Description

Twig, a PHP template language, has a vulnerability in versions prior to 3.26.0 where it memoizes IntlDateFormatter and NumberFormatter instances keyed by template-controlled filter arguments. This behavior can cause many ICU formatter objects to remain in memory for the lifetime of the Twig\Environment, potentially leading to resource exhaustion. The issue is fixed in version 3.26.0.

References

Community reviews

Loading reviews…