Skip to main content
VulnerabilityPublished Updated

CVE-2026-109618: php8.1, php8.3, php8.5 vulnerabilities

Affects php8.1Source GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-109618· Critical 9.2

Exploited in the wild · KEV due 29 Oct 2026 · public exploit available (Exploit-DB) · fixed in 8.1.2-1ubuntu2.28 : patch php8.1 now.

Data as of 27 Oct 2026, 06:42 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
Patch
Available – fixed in 8.1.2-1ubuntu2.28, 8.3.6-0ubuntu0.24.04.13, 8.5.9-0ubuntu2.1 +1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Exploited in the wild: evidence found.

    Listed in CISA KEV 5 days after disclosure

  3. Observed by OffSeq Mirage: evidence found.

    81 honeypot hits, first 43 hours after disclosure

Timeline

  1. CVE ID reserved

    by PHP Group

    , 9 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. First Exploit-DB entry (opens in a new tab)

    PHP2Shell (CVE-2026-109618) - PHP core versions after v5.4 - RCE

    , 1 day after disclosure

  4. First seen by OffSeq Mirage

    from 9 attacker networks; activity in Portugal, Netherlands, Poland, United States and 12 more

    , 43 hours after disclosure

  5. In Threat Radar

    record ingested

    , 5 days after disclosure

  6. , 5 days after disclosure

  7. , 6 days after disclosure

  8. KEV remediation due

    US federal deadline

    , 8 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), OffSeq Mirage (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10php8.5pkg:deb/ubuntu/php8.5?arch=source&distro=stonkingOther threatsAffected
  • <8.5.9-0ubuntu2.1
Fixed in
  • 8.5.9-0ubuntu2.1
Ubuntu 26.04 LTSphp8.5pkg:deb/ubuntu/php8.5?arch=source&distro=resoluteOther threatsAffected
  • <8.5.4-0ubuntu1.5
Fixed in
  • 8.5.4-0ubuntu1.5
Ubuntu 24.04 LTSphp8.3pkg:deb/ubuntu/php8.3?arch=source&distro=nobleOther threatsAffected
  • <8.3.6-0ubuntu0.24.04.13
Fixed in
  • 8.3.6-0ubuntu0.24.04.13
Ubuntu 22.04 LTSphp8.1pkg:deb/ubuntu/php8.1?arch=source&distro=jammyOther threatsAffected
  • <8.1.2-1ubuntu2.28
Fixed in
  • 8.1.2-1ubuntu2.28

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

It was discovered that PHP incorrectly handled out-of-memory conditions while processing requests. A remote attacker could use this issue to execute arbitrary code. (CVE-2026-109618) It was discovered that PHP incorrectly managed internal request state across worker reuse. A remote attacker could use this issue to execute arbitrary code. (CVE-2026-109619)

References

Community reviews

Loading reviews…