Skip to main content
VulnerabilityPublished Updated

CVE-2026-94603: The `podman run` command can be instructed to disable almost all sandboxing by image annotation

Affects github.com/containers/podman/v4Source GCVE Database

0
Compare
Authoritative record:CVE-2026-94603· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical : upgrade to 5.8.8 as a priority.

Data as of 3 Nov 2026, 16:14 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.8.8, 6.1.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade github.com/containers/podman/v4 and github.com/containers/podman/v5 to 5.8.8; go.podman.io/podman/v6 to 6.1.3.

Affected software

ProductAffectedFixed in
Gogithub.com/containers/podman/v4Affected
  • >=4.4.0 <5.8.8
Fixed in
  • 5.8.8
Gogo.podman.io/podman/v6Affected
  • >=6.0.0 <6.1.3
Fixed in
  • 6.1.3
Gogithub.com/containers/podman/v5Affected
  • >=4.4.0 <5.8.8
Fixed in
  • 5.8.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Podman to versions 5.8.8 or later, or 6.1.3 or later, where the vulnerable functionality has been removed. As a workaround, scan images for the 'io.podman.annotations.checkpoint.runtime.name' annotation and reject those containing it, although Podman currently lacks automated support for this scanning. Rootless containers are not affected by this vulnerability.

Description

Podman versions 4.4.0 through before 5.8.8 and 6.0.0 through before 6.1.3 contain a vulnerability where the 'podman run' command can be tricked into disabling almost all sandboxing by using an image annotated as a checkpoint. This allows the image to override user-specified container creation options, potentially granting full capabilities and control over the container sandbox. The functionality enabling this behavior has been removed in patched versions.

References

Community reviews

Loading reviews…