Skip to main content
VulnerabilityPublished Updated

CVE-2026-42305: Poetry · Dulwich has an arbitrary file write via NTFS-hostile tree entries on Windows

Affects poetrySource GCVE Database

0
Compare
Authoritative record:CVE-2026-42305· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade to 2.4.1_3 soon.

Data as of 30 Oct 2026, 08:16 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.1_3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade poetry to 2.4.1_3.

Affected software

ProductAffectedFixed in
Homebrewpoetrypkg:brew/poetryOther threatsAffected
  • >=1.2.0 <2.4.1_3
Fixed in
  • 2.4.1_3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should upgrade to Dulwich version 2.4.1_3 or later. The fix enforces proper path validation and honors protective configuration options. There is no effective pre-patch workaround; setting core.protectNTFS to true on affected versions does not mitigate the issue due to a configuration lookup bug. Users unable to upgrade should avoid cloning, fetching, or checking out untrusted repositories on Windows with Dulwich.

Description

Dulwich versions from 1.2.0 up to but not including 2.4.1_3 on Windows allow arbitrary file write via specially crafted Git tree entries containing NTFS-hostile path elements. This can lead to remote code execution when cloning or checking out malicious repositories. The vulnerability arises because Dulwich's path-element validator accepted filenames with backslashes, NTFS alternate-data-stream markers, and certain 8.3 short-name aliases, enabling attackers to plant files inside the victim's .git directory or escape the working tree. The issue is fixed in Dulwich 2.4.1_3.

References

Community reviews

Loading reviews…