Skip to main content
VulnerabilityPublished Updated

CVE-2026-42563: Poetry · Dulwich Vulnerable to Command Injection via Merge Driver Path

Affects poetrySource GCVE Database

0
Compare
Authoritative record:CVE-2026-42563· High 7.7

Not known to be exploited · CVSS 7.7 High : upgrade to 2.4.1_3 soon.

Data as of 30 Oct 2026, 08:16 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.1_3
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade poetry to 2.4.1_3.

Affected software

ProductAffectedFixed in
Homebrewpoetrypkg:brew/poetryOther threatsAffected
  • >=2.2.0 <2.4.1_3
Fixed in
  • 2.4.1_3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in Poetry version 2.4.1_3 that fixes this command injection vulnerability. Users should upgrade to version 2.4.1_3 or later to remediate this issue. Until patched, users should avoid merging untrusted branches that could contain malicious file paths and review merge driver configurations that use the `%P` placeholder.

Description

Dulwich's merge driver functionality is vulnerable to command injection via the `%P` placeholder in merge driver commands. An attacker who can cause a victim to merge an untrusted branch with malicious file paths can execute arbitrary commands on the victim's system. This requires the victim to have a merge driver configured that uses the `%P` placeholder. The vulnerability affects Poetry versions from 2.2.0 up to but not including 2.4.1_3 and has been assigned CVE-2026-42563.

References

Community reviews

Loading reviews…