Skip to main content
CVE-2026-59199VulnerabilityPublished Updated

Prior to 12.3.0, Pillow public image coordinate APIs can trigger a native heap out-of-bounds write when given

Affects pillowSource GCVE Database

0
Compare
Authoritative record:CVE-2026-59199· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 12.3.0 : patch pillow soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 12.3.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSpillowpkg:deb/ubuntu/pillow?arch=source&distro=resoluteOther threatsAffected
  • 11.3.0-1ubuntu1 – 12.1.1-2ubuntu1.4
9 affected builds
Fixed in–
Ubuntu 24.04 LTSpillowpkg:deb/ubuntu/pillow?arch=source&distro=nobleOther threatsAffected
  • 10.0.0-1 – 10.2.0-1ubuntu1.4
8 affected builds
Fixed in–
Ubuntu 22.04 LTSpillowpkg:deb/ubuntu/pillow?arch=source&distro=jammyOther threatsAffected
  • 8.1.2+dfsg-0.3 – 9.0.1-1ubuntu0.6
10 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSpillowpkg:deb/ubuntu/pillow?arch=source&distro=esm-infra/focalOther threatsAffected
  • 6.1.0-1 – 7.0.0-4ubuntu0.9+esm1
15 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSpillow-python2pkg:deb/ubuntu/pillow-python2?arch=source&distro=esm-apps/focalOther threatsAffected
  • 6.2.1-3 – 6.2.1-3ubuntu0.1~esm2
4 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSpillowpkg:deb/ubuntu/pillow?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 4.1.1-3build2 – 5.1.0-1ubuntu0.8+esm2
13 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to Pillow version 12.3.0 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory.

Description

Pillow, a Python imaging library, has a vulnerability in its public image coordinate APIs prior to version 12.3.0. Specifically, when coordinates near the signed 32-bit integer limits are used in Image.paste(), Image.crop(), or Image.alpha_composite(), a native heap out-of-bounds write can occur. This flaw can lead to a denial of service or potentially other impacts related to memory corruption. The issue is resolved in Pillow version 12.3.0.

References

Community reviews

Loading reviews…