CVE-2024-39400: Project community edition · Magento DOM-based Cross-Site Scripting (XSS) vulnerability
Affects magento/project-community-editionSource GCVE Database
Not known to be exploited · CVSS 8.1 High · fixed in 2.4.7-p2 : patch magento/project-community-edition soon.
Data as of 4 Nov 2026, 18:30 UTC
- Patch
- Available – fixed in 2.4.7-p2, 2.4.6-p7, 2.4.5-p9 +1
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Aug 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagistmagento/project-community-edition | Affected
| Fixed in– |
| Packagistmagento/community-edition | Affected
| Fixed in
|
| Packagistmagento/community-edition | Affected
| Fixed in
|
| Packagistmagento/community-edition | Affected
| Fixed in
|
| Packagistmagento/community-edition | Affected
| Fixed in
|
| Packagistmagento/community-edition | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading to Magento versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, or 2.4.4-p10. Applying these official fixes will remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
Magento Project Community Edition versions up to 2.4.7-p1 and certain earlier patched releases contain a DOM-based Cross-Site Scripting (XSS) vulnerability (CVE-2024-39400). This flaw allows an authenticated admin user to inject and execute arbitrary JavaScript in another admin's browser session, potentially compromising confidentiality and integrity. Exploitation requires user interaction, such as clicking a malicious link. The vulnerability has been assigned a high severity score of 8.1 and is fixed in versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, and 2.4.4-p10.