Skip to main content
VulnerabilityPublished Updated

CVE-2024-39403: Project community edition · Magento Stored Cross-Site Scripting (XSS) vulnerability

Affects magento/project-community-editionSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.6 High · fixed in 2.4.7-p2 : patch magento/project-community-edition soon.

Data as of 4 Nov 2026, 17:16 UTC

CVSS 3.1 base score
7.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.7-p2, 2.4.6-p7, 2.4.5-p9 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Packagistmagento/project-community-editionAffected
  • <=2.0.2
Fixed in–
Packagistmagento/community-editionAffected
  • >=2.4.7-beta1 <2.4.7-p2
Fixed in
  • 2.4.7-p2
Packagistmagento/community-editionAffected
  • >=2.4.6-p1 <2.4.6-p7
Fixed in
  • 2.4.6-p7
Packagistmagento/community-editionAffected
  • >=2.4.5-p1 <2.4.5-p9
Fixed in
  • 2.4.5-p9
Packagistmagento/community-editionAffected
  • >=2.4.4-p1 <2.4.4-p10
Fixed in
  • 2.4.4-p10
Packagistmagento/community-editionAffected
  • =2.4.7
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Magento versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a low-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. Confidentiality impact is high due to the attacker being able to exfiltrate sensitive information.

References

Community reviews

Loading reviews…