CVE-2024-39407: Project community edition · Magento Improper Authorization vulnerability
Affects magento/project-community-editionSource GCVE Database
Not known to be exploited · CVSS 4.3 Medium · fixed in 2.4.7-p2 : update magento/project-community-edition when convenient.
Data as of 4 Nov 2026, 18:29 UTC
- Patch
- Available – fixed in 2.4.7-p2, 2.4.6-p7, 2.4.5-p9 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Aug 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagistmagento/project-community-edition | Affected
| Fixed in– |
| Packagistmagento/community-edition | Affected
| Fixed in
|
| Packagistmagento/community-edition | Affected
| Fixed in
|
| Packagistmagento/community-edition | Affected
| Fixed in
|
| Packagistmagento/community-edition | Affected
| Fixed in
|
| Packagistmagento/community-edition | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in Magento versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, and 2.4.4-p10. Users should upgrade to these fixed versions to remediate the vulnerability. No additional mitigations or workarounds are indicated by the vendor advisory.
Description
Magento Project Community Edition versions up to 2.4.7-p1 and earlier are affected by an Improper Authorization vulnerability (CVE-2024-39407). This flaw allows a low-privileged attacker to bypass security controls and modify minor information without requiring user interaction. The vulnerability has a medium severity score of 4.3 and impacts several patched versions prior to 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, and 2.4.4-p10.