Skip to main content
VulnerabilityPublished Updated

CVE-2026-49877: Org.apache.activemq:apache activemq: Apache ActiveMQ Improper Authorization vulnerability

Affects org.apache.activemq:apache-activemqSource GCVE Database

0
Compare
Authoritative record:CVE-2026-49877· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade to 5.19.8 soon.

Data as of 4 Nov 2026, 20:36 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.19.8, 6.2.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.activemq:apache-activemq to 5.19.8; org.apache.activemq:apache-activemq to 6.2.7.

Affected software

ProductAffectedFixed in
Mavenorg.apache.activemq:apache-activemqAffected
  • <5.19.8
Fixed in
  • 5.19.8
Mavenorg.apache.activemq:apache-activemqAffected
  • >=6.0.0 <6.2.7
Fixed in
  • 6.2.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache ActiveMQ to version 5.19.8 or 6.2.7 or later, where the improper authorization issue is fixed. No other mitigations are specified or required beyond applying the official patch.

Description

Apache ActiveMQ contains an improper authorization vulnerability allowing authenticated low-privilege Web Console users to access administrative paths (/admin/*) by default due to incorrect Jetty settings. This affects versions before 5.19.8 and from 6.0.0 before 6.2.7. The issue is fixed in versions 5.19.8 and 6.2.7. The vulnerability has a high severity with a CVSS score of 8.1.

References

Community reviews

Loading reviews…