CVE-2026-55956: Org.apache.tomcat.embed:tomcat embed core: Apache Tomcat has an Improper Authorization vulnerability
Affects org.apache.tomcat.embed:tomcat-embed-coreSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium : upgrade to 11.0.23 when convenient.
Data as of 4 Nov 2026, 21:27 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 11.0.23, 10.1.56, 9.0.119
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-catalina to 11.0.23; org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-catalina to 10.1.56; org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-catalina to 9.0.119.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.apache.tomcat.embed:tomcat-embed-core | Affected
| Fixed in
|
| Mavenorg.apache.tomcat.embed:tomcat-embed-core | Affected
| Fixed in
|
| Mavenorg.apache.tomcat.embed:tomcat-embed-core | Affected
| Fixed in
|
| Mavenorg.apache.tomcat.embed:tomcat-embed-core | Affected
| Fixed in– |
| Mavenorg.apache.tomcat.embed:tomcat-embed-core | Affected
| Fixed in– |
| Mavenorg.apache.tomcat:tomcat | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade affected Apache Tomcat versions to 11.0.23, 10.1.56, or 9.0.119 where the vulnerability is fixed. Since a patch is available and official fixes have been released, applying these updates is the recommended mitigation. No additional vendor advisories indicate alternative mitigations or that no action is required.
Description
Apache Tomcat versions from 7.0.0 through 7.0.109, 8.5.0 through 8.5.100, 9.0.0.M1 through 9.0.118, 10.1.0-M1 through 10.1.55, and 11.0.0-M1 through 11.0.22 contain an improper authorization vulnerability. This flaw causes security constraints for the default servlet to ignore method or method omission configurations, potentially allowing unauthorized access. Fixed versions are 11.0.23, 10.1.56, and 9.0.119. The vulnerability has a CVSS score of 6.5 (medium severity).
References
- nvd.nist.gov/vuln/detail/CVE-2026-55956 (opens in a new tab)
- github.com/apache/tomcat/commit/3f6bd2ba5e53d1f340bbe5ad2d42a28b29440b7a (opens in a new tab)
- github.com/apache/tomcat/commit/9c3b1efb74fd04f77639720af1d48a8f664ad9bb (opens in a new tab)
- github.com/apache/tomcat/commit/a0374c450970760efafbd8806a1db278830ba7bd (opens in a new tab)
- github.com/apache/tomcat (opens in a new tab)
- lists.apache.org/thread/dcjdcnnnww9hhdm016hr0l7hpw1bzjfp (opens in a new tab)
- tomcat.apache.org/security-10.html (opens in a new tab)
- tomcat.apache.org/security-11.html (opens in a new tab)
- tomcat.apache.org/security-9.html (opens in a new tab)
- openwall.com/lists/oss-security/2026/06/29/25 (opens in a new tab)