Skip to main content
CVE-2026-55957VulnerabilityPublished Updated

Org.apache.tomcat.embed:tomcat embed core: Apache Tomcat has a Missing Critical Step in Authentication vulnerability

Affects org.apache.tomcat.embed:tomcat-embed-coreSource GCVE Database

0
Compare
Authoritative record:CVE-2026-55957· High 7.3

Not known to be exploited · CVSS 7.3 High : upgrade to 11.0.5 soon.

Data as of 4 Nov 2026, 17:14 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 11.0.5, 10.1.37, 9.0.101
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-catalina to 11.0.5; org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-catalina to 10.1.37; org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-catalina to 9.0.101.

Affected software

ProductAffectedFixed in
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=11.0.0-M1 <11.0.5
Fixed in
  • 11.0.5
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=10.1.0-M1 <10.1.37
Fixed in
  • 10.1.37
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=9.0.0.M1 <9.0.101
Fixed in
  • 9.0.101
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=8.5.0 <=8.5.100
Fixed in–
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • <=7.0.109
Fixed in–
Mavenorg.apache.tomcat:tomcatAffected
  • >=11.0.0-M1 <11.0.5
Fixed in
  • 11.0.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to Apache Tomcat versions 11.0.5, 10.1.37, or 9.0.101 or later, where this vulnerability has been fixed. No additional mitigation steps are indicated beyond applying these official patches.

Description

Apache Tomcat contains a vulnerability in its JNDIRealm authentication when configured to use GSSAPI. This flaw allows attackers to bypass password verification and authenticate without providing the correct credentials. The issue affects multiple versions across the 7.x, 8.5.x, 9.x, 10.1.x, and 11.x branches. Fixed versions have been released in 11.0.5, 10.1.37, and 9.0.101.

References

Community reviews

Loading reviews…