Skip to main content
CVE-2026-53917VulnerabilityPublished Updated

Org.apache.activemq:apache activemq: Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Client, Apache ActiveMQ

Affects org.apache.activemq:apache-activemqSource GCVE Database

0
Compare
Authoritative record:CVE-2026-53917· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 5.19.8 soon.

Data as of 4 Nov 2026, 21:27 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.19.8, 6.2.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.activemq:apache-activemq and org.apache.activemq:activemq-all and org.apache.activemq:activemq-client and org.apache.activemq:activemq-broker to 5.19.8; org.apache.activemq:apache-activemq and org.apache.activemq:activemq-all and org.apache.activemq:activemq-client and org.apache.activemq:activemq-broker to 6.2.7.

Affected software

ProductAffectedFixed in
Mavenorg.apache.activemq:apache-activemqAffected
  • <5.19.8
Fixed in
  • 5.19.8
Mavenorg.apache.activemq:apache-activemqAffected
  • >=6.0.0 <6.2.7
Fixed in
  • 6.2.7
Mavenorg.apache.activemq:activemq-allAffected
  • <5.19.8
Fixed in
  • 5.19.8
Mavenorg.apache.activemq:activemq-allAffected
  • >=6.0.0 <6.2.7
Fixed in
  • 6.2.7
Mavenorg.apache.activemq:activemq-clientAffected
  • <5.19.8
Fixed in
  • 5.19.8
Mavenorg.apache.activemq:activemq-clientAffected
  • >=6.0.0 <6.2.7
Fixed in
  • 6.2.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade affected Apache ActiveMQ components to version 5.19.8 or 6.2.7, where this vulnerability is fixed. Since a patch is available, applying the official update is the recommended remediation.

Description

A vulnerability in Apache ActiveMQ allows an authenticated user to cause a denial of service (DoS) by sending a crafted OpenWire message with an excessively large encoded size value. This triggers an out-of-memory (OOM) condition and crashes the broker. The issue affects multiple Apache ActiveMQ components before versions 5.19.8 and from 6.0.0 before 6.2.7. Upgrading to versions 5.19.8 or 6.2.7 resolves the issue.

References

Community reviews

Loading reviews…