CVE-2024-39418: Project community edition · Magento Improper Authorization vulnerability
Affects magento/project-community-editionSource GCVE Database
Not known to be exploited · CVSS 5.4 Medium · fixed in 2.4.7-p2 : update magento/project-community-edition when convenient.
Data as of 4 Nov 2026, 18:29 UTC
- Patch
- Available – fixed in 2.4.7-p2, 2.4.6-p7, 2.4.5-p9 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Aug 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagistmagento/project-community-edition | Affected
| Fixed in– |
| Packagistmagento/community-edition | Affected
| Fixed in
|
| Packagistmagento/community-edition | Affected
| Fixed in
|
| Packagistmagento/community-edition | Affected
| Fixed in
|
| Packagistmagento/community-edition | Affected
| Fixed in
|
| Packagistmagento/community-edition | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in Magento versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, and 2.4.4-p10. Users should upgrade to these fixed versions to remediate the vulnerability. Since this is not a cloud service, manual patching is required.
Description
Magento project community edition versions up to and including certain patch levels of 2.4.7, 2.4.6, 2.4.5, and 2.4.4, as well as versions <=2.0.2, contain an improper authorization vulnerability (CVE-2024-39418). This flaw allows a low-privileged attacker to bypass security controls and view or edit low-sensitivity information without requiring user interaction. The vulnerability has a medium severity rating with a CVSS score of 5.4. Fixed versions have been released for all affected branches.