Skip to main content
VulnerabilityPublished Updated

CVE-2024-39399: Project community edition · Magento Path Traversal vulnerability

Affects magento/project-community-editionSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.7 High · fixed in 2.4.7-p2 : patch magento/project-community-edition soon.

Data as of 4 Nov 2026, 18:30 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.7-p2, 2.4.6-p7, 2.4.5-p9 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Packagistmagento/project-community-editionAffected
  • <=2.0.2
Fixed in–
Packagistmagento/community-editionAffected
  • >=2.4.7-beta1 <2.4.7-p2
Fixed in
  • 2.4.7-p2
Packagistmagento/community-editionAffected
  • >=2.4.6-p1 <2.4.6-p7
Fixed in
  • 2.4.6-p7
Packagistmagento/community-editionAffected
  • >=2.4.5-p1 <2.4.5-p9
Fixed in
  • 2.4.5-p9
Packagistmagento/community-editionAffected
  • >=2.4.4-p1 <2.4.4-p10
Fixed in
  • 2.4.4-p10
Packagistmagento/community-editionAffected
  • =2.4.7
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied immediately. Fixed versions include 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, and 2.4.4-p10. Upgrading to these versions will remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

Magento project community edition versions up to certain patched releases suffer from a path traversal vulnerability (CVE-2024-39399) that allows a low-privileged attacker to read arbitrary files outside restricted directories without user interaction. This vulnerability affects multiple versions including 2.4.4 through 2.4.7 and earlier. The issue has been fixed in patch releases 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, and 2.4.4-p10.

References

Community reviews

Loading reviews…