CVE-2026-119197: Prowler · pyasn1 has quadratic-complexity denial of service in binary REAL decoding
Affects prowlerSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 5.47.0 soon.
Data as of 31 Oct 2026, 16:35 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 5.47.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade prowler to 5.47.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewprowlerpkg:brew/prowlerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade pyasn1 to version 0.6.5 or later, where the vulnerability is fixed. Until upgrading, applications should reject or strictly limit ASN.1 inputs containing REAL values, especially those with large mantissas, before passing them to pyasn1 decoders.
Description
pyasn1 versions up to 0.6.4 contain a denial of service vulnerability in the decoding of binary-encoded ASN.1 REAL values with large mantissas. The decoding process is quadratic in the mantissa length, causing excessive CPU consumption when processing crafted inputs. This affects BER, CER, and DER decoders using the RealPayloadDecoder. The issue is fixed in pyasn1 version 0.6.5.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-mm57-4v3p-rchx (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-119197 (opens in a new tab)
- github.com/pyasn1/pyasn1/pull/132 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/ce3ec3390784780a530047e0e77be5ff457636a4 (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.5 (opens in a new tab)