CVE-2026-119196: Prowler · pyasn1 has quadratic CPU consumption in constructed BIT STRING decoding
Affects prowlerSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 5.47.0 soon.
Data as of 31 Oct 2026, 16:35 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 5.47.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade prowler to 5.47.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewprowlerpkg:brew/prowlerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix for this vulnerability is available in pyasn1 version 5.47.0. Users should upgrade to version 5.47.0 or later to remediate this issue. No other mitigation is required if the fix is applied. Applications should also consider input validation and limits on ASN.1 fragment counts to reduce exposure, but the primary remediation is upgrading to the fixed version.
Description
CVE-2026-119196 is a high-severity vulnerability in pyasn1 versions from 3.4.0 up to but not including 5.47.0. It causes quadratic CPU consumption when decoding constructed BIT STRING values with many fragments, leading to potential CPU exhaustion and denial of service. The issue affects BER and CER decoders and certain schema-driven DER decoding paths. The vulnerability arises from inefficient bit-shifting operations during decoding. A fix is available in pyasn1 version 5.47.0.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-2qm8-x737-gmw5 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-119196 (opens in a new tab)
- github.com/pyasn1/pyasn1/pull/132 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/73ba7b043cc7e92cb37f16f2c955bff93b0e6f6c (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.5 (opens in a new tab)