Prowler: pyasn1 has quadratic-time denial of service in constructed string and indefinite-length ANY decoding
Affects prowlerSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 5.47.0 soon.
Data as of 31 Oct 2026, 16:36 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 5.47.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade prowler to 5.47.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewprowlerpkg:brew/prowlerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in pyasn1 version 5.47.0. Users should upgrade to version 5.47.0 or later to remediate this vulnerability. Until upgraded, applications should implement input validation and resource usage limits to mitigate potential denial of service. No other vendor advisory mitigation instructions are provided.
Description
pyasn1 versions 0.6.4 and earlier contain a quadratic-time denial of service vulnerability in the decoding of constructed OCTET STRINGs, constructed character strings, and indefinite-length ANY types. The decoder repeatedly concatenates fragments inefficiently, causing CPU usage to grow quadratically with the number of fragments. This can lead to CPU exhaustion if an attacker supplies crafted ASN.1 input to an affected decoder. The vulnerability affects BER and CER decoding paths and certain non-conforming DER inputs. No confidentiality or integrity impact is reported. The issue is fixed in version 5.47.0.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-9m75-vc3g-4x39 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-119195 (opens in a new tab)
- github.com/pyasn1/pyasn1/pull/132 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/4ce00797c594b59c1fd6b86d9ebc3ba87b7ec9f9 (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.5 (opens in a new tab)