psqlODBC copies the reply to a large-object read (loread) into the application's buffer using the length sent by the
Source GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 18.00.0006 soon.
Data as of 2 Nov 2026, 23:29 UTC
Thin evidence
One scorer or none| CNA (PostgreSQL) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 18.00.0006
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade psqlODBC to 18.00.0006.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PostgreSQLpsqlODBC | Affected
| Fixed in
|
GitHubpsqlODBCpkg:github/psqlODBCOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade psqlODBC to version 18.00.0006 or later where this vulnerability is fixed. Until then, avoid connecting to untrusted servers or those not secured under current SSL settings to reduce risk. No other mitigations are specified.
Description
A buffer overflow vulnerability exists in psqlODBC versions before 18.00.0006 where the client copies data from a large-object read (loread) into its buffer using the length provided by the server without verifying the buffer size. This can allow a malicious or untrusted server to overwrite adjacent memory in the client process. Triggering the vulnerability requires fetching any large-object column.