Skip to main content
CVE-2026-6477VulnerabilityPublished Updated

Red Hat Security Advisory: libpq security update

Affects Red Hat libpqSource GCVE Database

0
Compare
Authoritative record:CVE-2026-6477· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade the Red Hat redhat/libpq package to 9.2.1 soon.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.2.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade the Red Hat redhat/libpq package to 9.2.1.

Affected software

ProductAffectedFixed in
Red Hatredhat/libpqpkg:rpm/redhat/libpqOther threatsAffected
  • >=9.2 <9.2.1
Fixed in
  • 9.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated libpq packages for Red Hat Enterprise Linux 9.2 to fix this vulnerability. Users should apply the security update as detailed in Red Hat advisory RHSA-2026:49908. For instructions on applying the update, refer to Red Hat's official guidance at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official patch.

Description

A buffer overflow vulnerability exists in the PostgreSQL libpq client library that allows a server superuser to overwrite client stack memory. This issue is addressed by a security update from Red Hat for libpq in Red Hat Enterprise Linux 9.2. The vulnerability is identified as CVE-2026-6477 and is rated with an important security impact by Red Hat Product Security.

References

Community reviews

Loading reviews…