CVE-2026-47736: Puma PROXY Protocol v1 Parser Allows Remote Memory Exhaustion
Affects pumaSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 8.0.2 soon.
Data as of 2 Nov 2026, 23:14 UTC
- Patch
- Available – fixed in 8.0.2, 7.2.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade puma to 8.0.2; puma to 7.2.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RubyGemspuma | Affected
| Fixed in
|
| RubyGemspuma | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Puma to version 7.2.1 or 8.0.2 or later, where this issue is fixed. If upgrading is not immediately possible, disable PROXY protocol v1 parsing by removing or commenting out the 'set_remote_address proxy_protocol: :v1' configuration. Additionally, restrict network access to Puma listeners that use PROXY protocol to trusted load balancers or reverse proxies only, and block arbitrary client TCP access using firewall or security group rules.
Description
Puma versions 5.5.0 through before 7.2.1 and 8.0.0 through before 8.0.2 with PROXY protocol v1 parsing enabled are vulnerable to remote memory exhaustion. An unauthenticated attacker can open a TCP connection and send bytes without CRLF, causing Puma to continuously append to an internal buffer, leading to unbounded memory growth and CPU usage. This may result in process or container out-of-memory conditions or degraded availability. The vulnerability only affects Puma servers configured with 'set_remote_address proxy_protocol: :v1'.
References
- github.com/puma/puma/security/advisories/GHSA-qpgp-93vx-g8v8 (opens in a new tab)
- github.com/puma/puma/commit/439c6136d9c2275721b7864db3ee78af7c80889f (opens in a new tab)
- github.com/puma/puma/commit/ebe9db3929ab8299d19c8f5b41e8ef4f4b22fa58 (opens in a new tab)
- github.com/puma/puma (opens in a new tab)
- github.com/puma/puma/releases/tag/v7.2.1 (opens in a new tab)
- github.com/puma/puma/releases/tag/v8.0.2 (opens in a new tab)
- github.com/rubysec/ruby-advisory-db/blob/master/gems/puma/CVE-2026-47736.yml (opens in a new tab)
- nvd.nist.gov/vuln/detail/cve-2026-47736 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-47736 (opens in a new tab)