CVE-2026-53720: pymonocypher · Potential heap buffer overflow on nb_blocks in argon2i_32 when provided buffer is too small
Affects pymonocypherSource GCVE Database
Not known to be exploited · CVSS 5.1 Medium : upgrade to 4.0.2.8 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.2.8
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade pymonocypher to 4.0.2.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIpymonocypher | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in pymonocypher version 4.0.2.8. Users should upgrade to version 4.0.2.8 or later to remediate this vulnerability. Alternatively, ensuring that the nb_blocks buffer is correctly sized before use can mitigate the risk. No additional vendor advisories indicate other mitigation steps.
Description
A heap buffer overflow vulnerability exists in pymonocypher's argon2i_32 function due to insufficient checking of the nb_blocks buffer size. If the buffer provided is too small, the function may write beyond its allocated memory, potentially corrupting the heap. This vulnerability is fixed in version 4.0.2.8 by verifying the buffer size before use. Users should upgrade to version 4.0.2.8 or later or ensure the nb_blocks buffer is correctly sized to mitigate the risk.