Python tornado:
Affects python-tornadoSource GCVE Database
Not known to be exploited · CVSS 5.4 Medium · fixed in 6.0.3+really5.1.1-3ubuntu0.1~esm3 : update python-tornado when convenient.
Data as of 6 Nov 2026, 23:24 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.0.3+really5.1.1-3ubuntu0.1~esm3, 6.1.0-3ubuntu0.1~esm4, 6.4.0-1ubuntu0.4 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10python-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 22.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 18.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-apps/bionicOther threats | Affected
| Fixed in– |
Ubuntu Pro 16.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-infra-legacy/xenialOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Tornado version 6.5.3 and in updated Ubuntu packages as detailed in the Ubuntu security notice USN-7950-1. Users should update to the fixed versions listed for their respective Ubuntu releases or upgrade Tornado to version 6.5.3 or later. Standard system updates on supported Ubuntu versions will apply the necessary patches. No additional mitigation is required once patched.
Description
Python Tornado versions 6.5.2 and below improperly handle the supplied reason phrase in HTTP headers without escaping it. This flaw allows injection of malicious content into HTTP headers or the default error page, potentially enabling HTTP header injection or cross-site scripting (XSS) attacks. The vulnerability affects the reason argument used in RequestHandler.set_status and tornado.web.HTTPError. The issue is fixed in Tornado version 6.5.3.
References
- ubuntu.com/security/CVE-2025-67724 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-67724 (opens in a new tab)
- github.com/tornadoweb/tornado/security/advisories/GHSA-pr2v-jx2c-wg9f (opens in a new tab)
- github.com/tornadoweb/tornado/commit/9c163aebeaad9e6e7d28bac1f33580eb00b0e421 (opens in a new tab)
- github.com/tornadoweb/tornado/releases/tag/v6.5.3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7950-1 (opens in a new tab)