Python tornado: Tornado versions before 6.5.9 contain an unbounded memory accumulation vulnerability in
Affects python-tornadoSource GCVE Database
Not known to be exploited · CVSS 8.7 High · fixed in 4.2.1-1ubuntu3.1+esm4 : patch python-tornado soon.
Data as of 6 Nov 2026, 23:24 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.2.1-1ubuntu3.1+esm4, 4.5.3-1ubuntu0.2+esm4, 6.4.0-1ubuntu0.6 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 22.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-apps/bionicOther threats | Affected
| Fixed in
|
Ubuntu Pro 16.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-infra-legacy/xenialOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available and users should update Tornado to the patched versions listed in the vendor advisory: 4.2.1-1ubuntu3.1+esm4, 4.5.3-1ubuntu0.2+esm4, 6.4.0-1ubuntu0.6, or 6.5.4-0.1ubuntu0.2. Applying these updates will remediate the vulnerability. Standard system updates on supported Ubuntu releases will apply the necessary patches.
Description
Tornado versions before 6.5.9 have a vulnerability in CurlAsyncHTTPClient that allows remote attackers to cause a denial of service by sending a specially crafted compressed response. This vulnerability involves an unbounded memory accumulation when processing gzip-encoded decompression bombs, which can exhaust system memory and crash the application process.
References
- ubuntu.com/security/CVE-2026-103262 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-103262 (opens in a new tab)
- github.com/tornadoweb/tornado/security/advisories/GHSA-chx6-46f5-w4vp (opens in a new tab)
- github.com/tornadoweb/tornado/commit/e412435febba4569c552c5c9054f1bf92bd171a9 (opens in a new tab)
- vulncheck.com/advisories/tornado-before-6.5.9-denial-of-service-via-curlasynchttpclient (opens in a new tab)
- ubuntu.com/security/notices/USN-8952-1 (opens in a new tab)