Python tornado: Prior to 6.6, Tornado's HTTP header parser accepts obsolete line folding and repeatedly concatenates
Affects python-tornadoSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium · fixed in 6.6 : update python-tornado when convenient.
Data as of 6 Nov 2026, 23:24 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 5.3 |
|---|
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10python-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu Pro 22.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-apps/bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Tornado to version 6.6 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory.
Description
Tornado, a Python web framework, has a vulnerability in its HTTP header parser prior to version 6.6. The parser accepts obsolete line folding and repeatedly concatenates short continuation lines, leading to quadratic CPU consumption on the IOLoop thread. An unauthenticated client can exploit this by sending a header block with many obsolete line-folding continuations, causing a denial of service by blocking other connections. This issue affects availability only and is fixed in Tornado version 6.6.
References
- ubuntu.com/security/CVE-2026-116577 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-116577 (opens in a new tab)
- github.com/tornadoweb/tornado/security/advisories/GHSA-pcg2-g6cj-q92c (opens in a new tab)
- github.com/tornadoweb/tornado/pull/3765 (opens in a new tab)
- github.com/tornadoweb/tornado/commit/1b7a1dc9f340f52de929852e8125aa12f25297c9 (opens in a new tab)
- github.com/tornadoweb/tornado/releases/tag/v6.6.0 (opens in a new tab)