CVE-2025-47287: Python tornado · When Tornado's multipart/form-data parser encounters certain errors, it logs a
Affects python-tornadoSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 6.1.0-3ubuntu0.1~esm2 : patch python-tornado soon.
Data as of 6 Nov 2026, 23:24 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.1.0-3ubuntu0.1~esm2, 6.4.0-1ubuntu0.2, 6.4.2-2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 15 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade the Ubuntu python-tornado to 6.1.0-3ubuntu0.1~esm2 (package) or 6.4.0-1ubuntu0.2 (package) or 6.4.2-2 (package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10python-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 22.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-apps/bionicOther threats | Affected
| Fixed in– |
Ubuntu Pro 16.04 LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-infra-legacy/xenialOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading Tornado to version 6.5.0 or later. Ubuntu users should update to the fixed package versions: 6.1.0-3ubuntu0.1~esm2, 6.4.0-1ubuntu0.2, or 6.4.2-2 as appropriate. As a temporary workaround, blocking HTTP requests with the Content-Type header set to multipart/form-data at a proxy can reduce exposure to this vulnerability.
Description
Tornado, a Python web framework, has a vulnerability in its multipart/form-data parser that causes excessive logging when encountering certain errors. This can be exploited by remote attackers to generate a high volume of logs, leading to a denial of service (DoS) due to synchronous logging. All Tornado versions prior to 6.5.0 are affected. The issue is patched in Tornado version 6.5.0 and later. As a workaround, blocking multipart/form-data content types at a proxy can mitigate the risk.
References
- ubuntu.com/security/CVE-2025-47287 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-47287 (opens in a new tab)
- github.com/tornadoweb/tornado/commit/b39b892bf78fe8fea01dd45199aa88307e7162f3 (opens in a new tab)
- github.com/tornadoweb/tornado/security/advisories/GHSA-7cx3-6m66-7c5m (opens in a new tab)
- ubuntu.com/security/notices/USN-7547-1 (opens in a new tab)