Skip to main content
VulnerabilityPublished Updated

CVE-2025-11183: QGIS QWC2 Cross-Site Scripting vulnerability

Affects qwc2Source GCVE Database

0
Compare
Authoritative record:CVE-2025-11183· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 2025.8.14 when convenient.

Data as of 5 Nov 2026, 23:23 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2025.8.14
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/AU:N/RE:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade qwc2 to 2025.8.14.

Affected software

ProductAffectedFixed in
npmqwc2Affected
  • <2025.8.14
Fixed in
  • 2025.8.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Cross-Site Scripting vulnerability in attribute table in QGIS QWC2 < 2025.08.14 allows an authorized attacker to plant arbitrary JavaScript code in the page.

References

Community reviews

Loading reviews…