Skip to main content
VulnerabilityPublished

CVE-2026-105924: qt6-qtbase security update

Affects qt6-qtbaseSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-105924· Medium 4.3

Not known to be exploited · CVSS 4.3 Medium : upgrade to 6.5.2-18.oe2403sp3 when convenient.

Data as of 4 Nov 2026, 16:47 UTC

CVSS 4.0 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Qt)CVSS 4.04.3
Patch
Available – fixed in 6.5.2-18.oe2403sp3
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U/R:U/RE:L/U:Green

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade qt6-qtbase to 6.5.2-18.oe2403sp3.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP3qt6-qtbasepkg:rpm/openEuler/qt6-qtbase&distro=openEuler-24.03-LTS-SP3Other threatsAffected
  • <6.5.2-18.oe2403sp3
Fixed in
  • 6.5.2-18.oe2403sp3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing these vulnerabilities is available in Qt version 6.5.2-18.oe2403sp3. Users and administrators should apply this update promptly to mitigate the risks. No additional vendor-advised mitigations or workarounds are indicated.

Description

Multiple security vulnerabilities have been identified in the Qt 6 QtBase modules, including null pointer dereference, out-of-bounds reads, and denial-of-service conditions triggered by specially crafted inputs. These affect components such as QCborValue JSON conversion, QAuthenticator NTLM authentication, QDomDocument XML parsing, and HTTP Cache-Control header parsing. The vulnerabilities can lead to application crashes, information disclosure, or denial of service. A security update fixing these issues is available in version 6.5.2-18.oe2403sp3.

References

Community reviews

Loading reviews…