Skip to main content
VulnerabilityPublished

CVE-2026-19248: qt6-qtbase security update

Affects qt6-qtbaseSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-19248· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 6.5.2-18.oe2403sp4 soon.

Data as of 4 Nov 2026, 16:47 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.5.2-18.oe2403sp4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/AU:N/R:U/V:D/RE:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade qt6-qtbase to 6.5.2-18.oe2403sp4.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP4qt6-qtbasepkg:rpm/openEuler/qt6-qtbase&distro=openEuler-24.03-LTS-SP4Other threatsAffected
  • <6.5.2-18.oe2403sp4
Fixed in
  • 6.5.2-18.oe2403sp4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available in Qt version 6.5.2-18.oe2403sp4 that fixes these vulnerabilities. Users should apply this official patch to remediate the issues. No additional mitigation is required beyond applying the update.

Description

Qt6-qtbase contains a denial-of-service vulnerability in its QDomDocument XML parsing component and an out-of-bounds read vulnerability in HTTP Cache-Control header parsing within the QtNetwork module. The Cache-Control header parsing flaw affects Qt versions from 6.0.0 through 6.8.8 and 6.9.0 through 6.11.1 on 64-bit builds, allowing remote attackers to cause application crashes via a crafted HTTP response header. The vulnerability is fixed in version 6.5.2-18.oe2403sp4.

References

Community reviews

Loading reviews…