CVE-2026-105924: qt6-qtbase security update
Affects qt6-qtbaseSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 4.3 Medium : upgrade to 6.5.2-18.oe2403sp1 when convenient.
Data as of 4 Nov 2026, 16:47 UTC
Thin evidence
One scorer or none| CNA (Qt) | CVSS 4.0 | 4.3 |
|---|
- Patch
- Available – fixed in 6.5.2-18.oe2403sp1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U/R:U/RE:L/U:GreenExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade qt6-qtbase to 6.5.2-18.oe2403sp1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP1qt6-qtbasepkg:rpm/openEuler/qt6-qtbase&distro=openEuler-24.03-LTS-SP1Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update is available in Qt version 6.5.2-18.oe2403sp1 that addresses all listed vulnerabilities. Users and administrators should apply this official fix promptly to mitigate the risks. No additional mitigation steps are indicated beyond updating to the fixed version.
Description
Multiple security vulnerabilities have been identified in the Qt 6 QtBase software toolkit, including NULL pointer dereference, out-of-bounds reads, and denial-of-service conditions affecting various Qt Core and Qt Network modules. These issues can lead to application crashes and potential exposure of sensitive information when processing crafted inputs or interacting with malicious servers. The vulnerabilities affect versions prior to 6.5.2-18.oe2403sp1 and have been addressed in that fixed release.
References
- openeuler.org/zh/security/security-bulletins/detail/?id=openEuler-SA-2026-4723 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-105924 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-105946 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-107157 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-19248 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-76151 (opens in a new tab)